Some trouble during Ubuntu 9.04 installing

Non tutte le ciambelle vengono col buco, si sà.

Così capita che la semplice installazione della nuova Ubuntu 9.04, effettuata ex-novo, abbia qualche sorpresa poco gradita a causa di qualche baco di troppo (comunque inevitabili il giorno del rilascio, i programmatori e i maintainer mica sono dei marziani) e della scelta non troppo azzeccata di eliminare dai media d’installazione, sia CD che DVD, un pacchetto evidentemente giudicato inutile per i più ma indispensabile per altri come wvdial.

Così mi sono ritrovato isolato dalla rete, con la necessità di effettuare gli aggiornamenti e di installare il software di cui necessito, con la mia amata/odiata datacard HSDPA non funzionante e nell’impossibilità di potermi procurare quanto necessario per far funzionare il tutto.

Ovviamente si tratta di un problema facilmente risolvibile, tuttavia ho deciso di scrivere queste poche righe  per aiutare coloro che, magari alle prime armi, davanti a questo problema non sanno dove sbattere la testa.

La datacard di cui sono in possesso è una momodesign MD-@ (le momo colorate per intenderci) che è ufficialmente supportata in  Windows e OSx, tuttavia funziona senza particolari problemi anche in Linux, in questo mio precedente post abbiamo visto come utilizzarla con una Ubuntu 8.04.

Dalla Ubuntu 8.10 il network manager dovrebbe essere in grado di gestire anche connessioni in banda larga mobile, tuttavia ciò non ha mai funzionato con la mia datacard. In giro per la rete ho letto di utenti a cui funziona senza bisogno di ulteriori configurazioni e di utenti che invece non sono riusciti in nessun modo a farla funzionare tramite il network manager.

Essendo io uno di quegli utenti che, appena autenticati, la prima operazione che fanno è aprire il terminale non ho perso nemmeno un secondo a capire che poteva essere a causare il malfunzionamento.

Ma veniamo al dunque, visto che anche nella nuova Ubuntu 9.04 è il network manager a doversi occupare di questa tipologia di connessioni probabilmente per questa ragione si è deciso di eliminare dai media d’installazione wvdial. Anche in questa nuova release non c’è stato verso di far funzionare la mia datacard col network manager così mi sono ritrovato senza gli strumenti potermi connettere alla rete.

La cosa che ho fatto, e che dovete fare anche voi nel caso in cui abbiate lo stesso problema, è installare i pacchetti riguardanti wvdial, con tanto di dipendenze risolte a mano come ai bei vecchi tempi, scaricati da un PC con connessione ad internet funzionante e trasferiti in qualche maniera sul PC incriminato.

I pacchetti da installare sono i seguenti:

  • libuniconf4.4
  • libwvstreams4.4-base
  • libwvstreams4.4-extras
  • libxplc0.3.13
  • wvdial_1.60.1

Il consiglio è di puntare il vostro browser a http://packages.ubuntu.com/jaunty/wvdial dal PC con la connessione ad internet funzionate e scaricare i pacchetti precedentemente indicati.

Una volta scaricati e trasferiti sul PC con la connessione non funzionante installarli con un semplice sudo dpkg -i *.deb una volta che vi siete collocati nella directory dove sono presenti i file appena trasferiti.

La configurazione di wvdial si esegue alla solita maniera, esattamente come indicato nel mio post segnalato all’inizio di questo.

Con questo è tutto, spero che la cosa possa risultare utili a coloro che si troveranno nella mia situazione.

Be Sociable, Share!

    Related post:

    Comments are closed.